Thursday, 5 April 2012

'E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.'


puneet@puneet-Studio-1458:~$ sudo apt-get purge erlang-syntax-tools
Reading package lists... Done
Building dependency tree      
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 erlang-crypto : Depends: erlang-base (= 1:13.b.3-dfsg-2ubuntu2) but 1:13.b.3-dfsg-2ubuntu3 is to be installed or
                          erlang-base-hipe (= 1:13.b.3-dfsg-2ubuntu2) but it is not going to be installed
 erlang-public-key : Depends: erlang-crypto (= 1:13.b.3-dfsg-2ubuntu3) but 1:13.b.3-dfsg-2ubuntu2 is to be installed
 erlang-ssl : Depends: erlang-crypto (= 1:13.b.3-dfsg-2ubuntu3) but 1:13.b.3-dfsg-2ubuntu2 is to be installed
 kdelibs-bin : Depends: libkdecore5 (= 4:4.5.5-0ubuntu2.1) but 4:4.8.2-0ubuntu1 is to be installed
 kdelibs5-dev : Depends: libkdecore5 (= 4:4.5.5-0ubuntu2.1) but 4:4.8.2-0ubuntu1 is to be installed
 kdelibs5-plugins : Depends: libkdecore5 (= 4:4.5.5-0ubuntu2.1) but 4:4.8.2-0ubuntu1 is to be installed
 kdoctools : Depends: libkdecore5 (= 4:4.5.5-0ubuntu2.1) but 4:4.8.2-0ubuntu1 is to be installed
 libc-dev-bin : Depends: libc6 (< 2.13) but 2.15-0ubuntu6 is to be installed
 libc6-dev : Depends: libc6 (= 2.12.1-0ubuntu10.4) but 2.15-0ubuntu6 is to be installed
 libkatepartinterfaces4 : Depends: libkdecore5 (= 4:4.5.5-0ubuntu2.1) but 4:4.8.2-0ubuntu1 is to be installed
 libkde3support4 : Depends: libkdecore5 (= 4:4.5.5-0ubuntu2.1) but 4:4.8.2-0ubuntu1 is to be installed
 libkdecore5 : Depends: libdlrestrictions1 (>= 0.14) but it is not installable
 libkdesu5 : Depends: libkdecore5 (= 4:4.5.5-0ubuntu2.1) but 4:4.8.2-0ubuntu1 is to be installed
 libkdeui5 : Depends: libkdecore5 (= 4:4.5.5-0ubuntu2.1) but 4:4.8.2-0ubuntu1 is to be installed
 libkdewebkit5 : Depends: libkdecore5 (= 4:4.5.5-0ubuntu2.1) but 4:4.8.2-0ubuntu1 is to be installed
 libkdnssd4 : Depends: libkdecore5 (= 4:4.5.5-0ubuntu2.1) but 4:4.8.2-0ubuntu1 is to be installed
 libkfile4 : Depends: libkdecore5 (= 4:4.5.5-0ubuntu2.1) but 4:4.8.2-0ubuntu1 is to be installed
 libkhtml5 : Depends: libkdecore5 (= 4:4.5.5-0ubuntu2.1) but 4:4.8.2-0ubuntu1 is to be installed
 libkimproxy4 : Depends: libkdecore5 (= 4:4.5.5-0ubuntu2.1) but 4:4.8.2-0ubuntu1 is to be installed
 libkio5 : Depends: libkdecore5 (= 4:4.5.5-0ubuntu2.1) but 4:4.8.2-0ubuntu1 is to be installed
 libkjsapi4 : Depends: libkdecore5 (= 4:4.5.5-0ubuntu2.1) but 4:4.8.2-0ubuntu1 is to be installed
 libkjsembed4 : Depends: libkdecore5 (= 4:4.5.5-0ubuntu2.1) but 4:4.8.2-0ubuntu1 is to be installed
 libkmediaplayer4 : Depends: libkdecore5 (= 4:4.5.5-0ubuntu2.1) but 4:4.8.2-0ubuntu1 is to be installed
 libknewstuff2-4 : Depends: libkdecore5 (= 4:4.5.5-0ubuntu2.1) but 4:4.8.2-0ubuntu1 is to be installed
 libknewstuff3-4 : Depends: libkdecore5 (= 4:4.5.5-0ubuntu2.1) but 4:4.8.2-0ubuntu1 is to be installed
 libknotifyconfig4 : Depends: libkdecore5 (= 4:4.5.5-0ubuntu2.1) but 4:4.8.2-0ubuntu1 is to be installed
 libkntlm4 : Depends: libkdecore5 (= 4:4.5.5-0ubuntu2.1) but 4:4.8.2-0ubuntu1 is to be installed
 libkparts4 : Depends: libkdecore5 (= 4:4.5.5-0ubuntu2.1) but 4:4.8.2-0ubuntu1 is to be installed
 libkpty4 : Depends: libkdecore5 (= 4:4.5.5-0ubuntu2.1) but 4:4.8.2-0ubuntu1 is to be installed
 libkrosscore4 : Depends: libkdecore5 (= 4:4.5.5-0ubuntu2.1) but 4:4.8.2-0ubuntu1 is to be installed
 libkrossui4 : Depends: libkdecore5 (= 4:4.5.5-0ubuntu2.1) but 4:4.8.2-0ubuntu1 is to be installed
 libktexteditor4 : Depends: libkdecore5 (= 4:4.5.5-0ubuntu2.1) but 4:4.8.2-0ubuntu1 is to be installed
 libkunitconversion4 : Depends: libkdecore5 (= 4:4.5.5-0ubuntu2.1) but 4:4.8.2-0ubuntu1 is to be installed
 libkutils4 : Depends: libkdecore5 (= 4:4.5.5-0ubuntu2.1) but 4:4.8.2-0ubuntu1 is to be installed
 libnepomuk4 : Depends: libkdecore5 (= 4:4.5.5-0ubuntu2.1) but 4:4.8.2-0ubuntu1 is to be installed
 libnepomukquery4a : Depends: libkdecore5 (= 4:4.5.5-0ubuntu2.1) but 4:4.8.2-0ubuntu1 is to be installed
 libnih1 : Depends: libc6 (< 2.13) but 2.15-0ubuntu6 is to be installed
 libplasma3 : Depends: libkdecore5 (= 4:4.5.5-0ubuntu2.1) but 4:4.8.2-0ubuntu1 is to be installed
 libqt4-core : Depends: libqtcore4 (= 4:4.7.0-0ubuntu4.4) but 4:4.8.1-0ubuntu1 is to be installed
               Depends: libqt4-network (= 4:4.7.0-0ubuntu4.4) but 4:4.8.1-0ubuntu1 is to be installed
               Depends: libqt4-xml (= 4:4.7.0-0ubuntu4.4) but 4:4.7.2-0ubuntu6.3 is to be installed
               Depends: libqt4-dbus (= 4:4.7.0-0ubuntu4.4) but 4:4.8.1-0ubuntu1 is to be installed
 libqt4-dbg : Depends: libqtcore4 (= 4:4.7.0-0ubuntu4.4) but 4:4.8.1-0ubuntu1 is to be installed
 libqt4-dbus : Depends: libqt4-xml (= 4:4.8.1-0ubuntu1) but 4:4.7.2-0ubuntu6.3 is to be installed
               Recommends: qdbus (= 4:4.8.1-0ubuntu1) but it is not installable
 libqt4-declarative : Depends: libqt4-network (= 4:4.7.0-0ubuntu4.4) but 4:4.8.1-0ubuntu1 is to be installed
                      Depends: libqtcore4 (= 4:4.7.0-0ubuntu4.4) but 4:4.8.1-0ubuntu1 is to be installed
 libqt4-designer : Depends: libqt4-xml (= 4:4.7.0-0ubuntu4.4) but 4:4.7.2-0ubuntu6.3 is to be installed
                   Depends: libqtcore4 (= 4:4.7.0-0ubuntu4.4) but 4:4.8.1-0ubuntu1 is to be installed
 libqt4-dev : Depends: libqt4-dbus (= 4:4.7.2-0ubuntu6.3) but 4:4.8.1-0ubuntu1 is to be installed
              Depends: libqt4-qt3support (= 4:4.7.2-0ubuntu6.3) but 4:4.7.0-0ubuntu4.4 is to be installed
              Depends: libqtcore4 (= 4:4.7.2-0ubuntu6.3) but 4:4.8.1-0ubuntu1 is to be installed
              Depends: libqtgui4 (= 4:4.7.2-0ubuntu6.3) but 4:4.7.0-0ubuntu4.4 is to be installed
              Depends: libqt4-network (= 4:4.7.2-0ubuntu6.3) but 4:4.8.1-0ubuntu1 is to be installed
              Depends: libqt4-svg (= 4:4.7.2-0ubuntu6.3) but 4:4.7.0-0ubuntu4.4 is to be installed
              Depends: libqt4-sql (= 4:4.7.2-0ubuntu6.3) but 4:4.7.0-0ubuntu4.4 is to be installed
              Depends: libqt4-script (= 4:4.7.2-0ubuntu6.3) but 4:4.7.0-0ubuntu4.4 is to be installed
              Depends: libqt4-scripttools (= 4:4.7.2-0ubuntu6.3) but 4:4.7.0-0ubuntu4.4 is to be installed
              Depends: libqt4-xmlpatterns (= 4:4.7.2-0ubuntu6.3) but 4:4.7.0-0ubuntu4.4 is to be installed
              Depends: libqt4-designer (= 4:4.7.2-0ubuntu6.3) but 4:4.7.0-0ubuntu4.4 is to be installed
              Depends: libqt4-help (= 4:4.7.2-0ubuntu6.3) but 4:4.7.0-0ubuntu4.4 is to be installed
              Depends: libqt4-test (= 4:4.7.2-0ubuntu6.3) but 4:4.7.0-0ubuntu4.4 is to be installed
              Depends: libqt4-declarative (= 4:4.7.2-0ubuntu6.3) but 4:4.7.0-0ubuntu4.4 is to be installed
              Depends: qt4-qmake (= 4:4.7.2-0ubuntu6.3) but 4:4.7.0-0ubuntu4.4 is to be installed
              Recommends: libqt4-opengl-dev (= 4:4.7.2-0ubuntu6.3) but 4:4.7.0-0ubuntu4.4 is to be installed
 libqt4-help : Depends: libqt4-network (= 4:4.7.0-0ubuntu4.4) but 4:4.8.1-0ubuntu1 is to be installed
               Depends: libqtcore4 (= 4:4.7.0-0ubuntu4.4) but 4:4.8.1-0ubuntu1 is to be installed
 libqt4-opengl : Depends: libqtcore4 (= 4:4.7.0-0ubuntu4.4) but 4:4.8.1-0ubuntu1 is to be installed
 libqt4-opengl-dev : Depends: libqt4-dev (= 4:4.7.0-0ubuntu4.4) but 4:4.7.2-0ubuntu6.3 is to be installed
 libqt4-qt3support : Depends: libqt4-network (= 4:4.7.0-0ubuntu4.4) but 4:4.8.1-0ubuntu1 is to be installed
                     Depends: libqt4-xml (= 4:4.7.0-0ubuntu4.4) but 4:4.7.2-0ubuntu6.3 is to be installed
                     Depends: libqtcore4 (= 4:4.7.0-0ubuntu4.4) but 4:4.8.1-0ubuntu1 is to be installed
 libqt4-script : Depends: libqt4-dbus (= 4:4.7.0-0ubuntu4.4) but 4:4.8.1-0ubuntu1 is to be installed
                 Depends: libqtcore4 (= 4:4.7.0-0ubuntu4.4) but 4:4.8.1-0ubuntu1 is to be installed
 libqt4-scripttools : Depends: libqtcore4 (= 4:4.7.0-0ubuntu4.4) but 4:4.8.1-0ubuntu1 is to be installed
 libqt4-sql : Depends: libqtcore4 (= 4:4.7.0-0ubuntu4.4) but 4:4.8.1-0ubuntu1 is to be installed
 libqt4-sql-mysql : Depends: libqtcore4 (= 4:4.7.0-0ubuntu4.4) but 4:4.8.1-0ubuntu1 is to be installed
 libqt4-sql-psql : Depends: libqtcore4 (= 4:4.7.0-0ubuntu4.4) but 4:4.8.1-0ubuntu1 is to be installed
 libqt4-sql-sqlite : Depends: libqtcore4 (= 4:4.7.0-0ubuntu4.4) but 4:4.8.1-0ubuntu1 is to be installed
 libqt4-svg : Depends: libqtcore4 (= 4:4.7.0-0ubuntu4.4) but 4:4.8.1-0ubuntu1 is to be installed
 libqt4-test : Depends: libqtcore4 (= 4:4.7.0-0ubuntu4.4) but 4:4.8.1-0ubuntu1 is to be installed
 libqt4-xml : Depends: libqtcore4 (= 4:4.7.2-0ubuntu6.3) but 4:4.8.1-0ubuntu1 is to be installed
 libqt4-xmlpatterns : Depends: libqt4-network (= 4:4.7.0-0ubuntu4.4) but 4:4.8.1-0ubuntu1 is to be installed
                      Depends: libqtcore4 (= 4:4.7.0-0ubuntu4.4) but 4:4.8.1-0ubuntu1 is to be installed
 libqtgui4 : Depends: libqt4-dbus (= 4:4.7.0-0ubuntu4.4) but 4:4.8.1-0ubuntu1 is to be installed
             Depends: libqtcore4 (= 4:4.7.0-0ubuntu4.4) but 4:4.8.1-0ubuntu1 is to be installed
 libsolid4 : Depends: libkdecore5 (= 4:4.5.5-0ubuntu2.1) but 4:4.8.2-0ubuntu1 is to be installed
 plasma-widget-telepathy-presence : Depends: libkdeui5 (>= 4:4.6) but 4:4.5.5-0ubuntu2.1 is to be installed
                                    Depends: libktpcommoninternalsprivate0 but it is not installable
                                    Depends: libplasma3 (>= 4:4.6) but 4:4.5.5-0ubuntu2.1 is to be installed
                                    Depends: libtelepathy-qt4-2 (>= 0.9.0+repack) but it is not installable
                                    Recommends: kde-telepathy but it is not installable
 qt4-demos : Depends: libqt4-dbus (= 4:4.7.0-0ubuntu4.4) but 4:4.8.1-0ubuntu1 is to be installed
             Depends: libqt4-network (= 4:4.7.0-0ubuntu4.4) but 4:4.8.1-0ubuntu1 is to be installed
             Depends: libqt4-xml (= 4:4.7.0-0ubuntu4.4) but 4:4.7.2-0ubuntu6.3 is to be installed
             Depends: libqtcore4 (= 4:4.7.0-0ubuntu4.4) but 4:4.8.1-0ubuntu1 is to be installed
 qt4-designer : Depends: libqt4-network (= 4:4.7.0-0ubuntu4.4) but 4:4.8.1-0ubuntu1 is to be installed
                Depends: libqt4-xml (= 4:4.7.0-0ubuntu4.4) but 4:4.7.2-0ubuntu6.3 is to be installed
                Depends: libqtcore4 (= 4:4.7.0-0ubuntu4.4) but 4:4.8.1-0ubuntu1 is to be installed
 qt4-dev-tools : Depends: libqt4-dbus (= 4:4.7.0-0ubuntu4.4) but 4:4.8.1-0ubuntu1 is to be installed
                 Depends: libqt4-xml (= 4:4.7.0-0ubuntu4.4) but 4:4.7.2-0ubuntu6.3 is to be installed
                 Depends: libqtcore4 (= 4:4.7.0-0ubuntu4.4) but 4:4.8.1-0ubuntu1 is to be installed
                 Depends: libqt4-network (= 4:4.7.0-0ubuntu4.4) but 4:4.8.1-0ubuntu1 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

1 comment:

smartsuite said...

Thanks for such social platform which give us variety of idea to explore ourself technically .This exposure give benefits to everyone to fit or to survive in global market which is very essential in the global era.
Time Attendance System

Post a Comment